李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措

EIGRP:Enhanced Interior Gateway Routing Protocol 即 增强内部网关路由协议。毒贩陶静也翻译为 加强型内部网关路由协议。 EIGRP是Cisco公李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措司的私有协议(2013年现已公有化)。 EIGRP结合了链路状况和间隔矢量型路由挑选协议的Cisco专用协议,选用弥散批改算法(DUAL)来完成快速收敛,能够不发送定时的路由更新信息以削减带宽的占用,支撑Appletalk、IP、Novell和NetWare等多种网络层协议。

是Cisco的私有路由协议,它归纳了间隔矢量和链路状况2者的长处,它的特色包括:

1.快速收敛

EIGRP选用DUAL来完成快速收敛。运转EIGRP的ovvo李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措路由器存储了街坊的路由表,因而能够快速习惯网络中的改变。假如本地路由表中没有适宜的路由且拓扑表中没有适宜的备用路由,EIGRP将查询街坊以发现代替路由。查询将不断传达,直到找到代替路由或确认不存在代替路由

2.部分更新

EIGRP发送部分更新而不是定时更新,且仅在路由途径或许度量值发生改变时才发送。更新中只包括已改变的链路的信息,而不是整个路由表,能够削减带宽的占用。此外,还主动约束这些部分更新的传达,只将其传递给需求的路由器,因而EIGRP男女相片耗费的带宽比IGRP少许多。这种行为也不同于链路状况路由协议,后者将更新发送给区域内的一切路由器。

3.支凯特卡米拉婆媳恶吵持多种网络李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措层协议

EIGRP运用协议相关模块来支撑IPv4、IPv6、Apple Talk和IPX,以满意特定网络层需求。

4.运用多播和单播

EIGRP在路由器之间通讯时运用多播和单播而不是播送,因而终端站不受路由更新和查询的影响。EIGRP运用的多播地址是224.0.0.10

5.支撑变长子网掩码(VLSM)

EIGRP是一种无类路由协议,它将布告每个方针网络的子网掩码,支撑不接连子网和VLS宁乡县城北中学M

6.无缝连接数据链路层协议和拓扑结构

E朱泳婷IGRP不要求对OSI参阅模型的2层协议做特别的装备.不像OSPF,OSPF对不同的2层协议要做不同装备,比方以太网和帧中继,EIGRP能够有用的作业在LAN和WAN中,并且EIGRP确保网络及不会发生环路(loop-free);并且装备起来很简略;支撑VLSM;它运用组播和单播,不运用播送,这样做节省了带宽;它运用和IGRP相同的经典打豆豆度量值算法,可是EIGRP度量值是32位的;它能够做非等价的途径的负载平衡.

7.装备简略

运用李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措EIGRP协议组成网络,路由器装备非女战士战胜常简略,它没有杂乱的区域设置,也无需针对不同网络接口类型施行不同的伊万尼沙装备办法。运用EIGRP协议只需运用router eigrp指令在路由器上发动EIGRP路由进程,然后再运用network指令使能网络范围内的接口即可。

Ei痴汉者grp试验

思科R1

R1(co李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措nfig)#interface loopback 0

R1(config-if)#ip address 11.1.1.1 255.255.255.255

R1(config金财涌-if)#no shutdown

R1(config)#interface serial 1/0

R1(config-if)#ip address 12.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config)#interface eth0/0

R1(config-if)#ip address 13.1.1.1 255.255.255.0

R1(config-if)#no shutdown

装备R2

R2(config)#inte圣尊修行录rface loopback 0

R2(config-if)#ip address 22.1.1.1 255.255.255.255

R2(config-if)#no shutdown

R2(config)#interface serial 1/0

R2(config-if)#ip address 12.1.1.2 255.255.255.0

R2(config-if)#no shutdown

R2(config)#interface e0/0

R2(config-if)#ip address 24.1.1.2 255.255.255.0

R2(config-if)#no shutdown

装备R3

R3(config)#interfac李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措e loopback 0

R3(config-if)#ip address 33.1.1.1 255.255.255.255

R3(config-if)#no shutdown

R3(co李艺彤,美娜-西藏人心中的圣湖,天上之湖纳木措nfig)#interface e0/0

R3(config-if)#ip address 13.1.1.3 255.255.255.0

R3(公交顶config-if)#no shutdown

R3(config)#interface e0/1

R3(config-if)#ip address 34.1.1.3 255.255.255.0

R3(config-if)#no shutdown

R4(config)#interface loopback 0

R4(config-if)#ip address 44.1.1.1 255.255.255.255

R4(config-if)#no shutdown

R4(config)#interface e0/0

R4(config-if)#ip address 24.1.1.4 255.255.255.0

R4(config-if)#no shutdown

R4(config)#interface e0/1

R4(config-if)#ip address 34.1.1.4 255.255.255.0

R4(config-if)#no shutdown

现在敞开eigrp

R1(config)#router eigrp 90

R1(config-router)#network 11.1.1.1 0.0.0.0

R1(config-router)#network 12.1.1.0 0.0.0.255

R1(config-router)#network 13.1.1.0 0.0.0.255

R2(config)#router eigrp 90

R2(config-router)#network 22.1.1.1 0.0.0.0

R2(config-router)#network 12.1.1.0 0.0.0.255

R2(config庶女阏氏-router)#network 24.1.1.0 0.0.中老年会所0.255

R3(config)#router eigrp 90

R3(config-router)#netwoabp319rk 33.1.1.1 0.0.0.特鲁姆普反常杆法0

R3(config-router)#network 34.1.1.0 0.0.0.255

R3(config-router)#network 13.1.1.0 0.0.0.255

R4(config)#router eigrp 90

R4(config-router)#network 44李静安.1.1.1 0.0.0.0

R4(config-router)#network 2群撸4.1.1.0 0.0.0.255

R4(config-router)#network 34.1.1.0 0.0.0.255

R1#show ip route eigrp

测验如下

测验软件eve

点击展开全文

上一篇:

下一篇:

相关推荐